Archive for the ‘VG224’ Category

The Cisco High-Density Packet Voice Digital Signal Processor (DSP) Module (PVDM2) enables Cisco Integrated Services Routers to provide high-density voice connectivity, conferencing, and transcoding capabilities in Cisco IP Communications solutions. PVDM stands for packet voice DSP module; it is the Cisco product name for the module that provides digital signal processing resources to a system. DSP stands for Digital Signal Processor; it is a generic Industry terminology. A PVDM module could be staffed with one or multiple DSPs.

PVDM2-8 = 8ch (G), 4ch (H), 4ch (M)

PVDM2-16 = 16ch (G), 6ch (H), 8ch (M)

PVDM2-32 = 32ch (G), 12ch (H), 16ch (M)

PVDM2-48 = 48ch (G), 18ch (H), 24ch (M)

PVDM2-64 = 64ch (G), 24ch (H), 32ch (M)

G=g711     H=G723.1,G728, G729, Gt29b, iLBC      M= G711, G729a, G729ab, G726, G722, Fax Relay

PVDM2-16 is one DSP chip (32=2, 48=3, 64=4)
PVDM2-8 is one DSP chip but less processing capacity than the DSP on the 16.
PVDM2-8 contains one TNETV2505GGW DSP; other PVDM2 modules contain 1 to 4 TNETV2510GGW DSPs (referred to C5510 in command outputs)

Codec Complexity and Flex Mode:

You can configure each DSP separately as either medium complexity, high complexity, or flex mode (C5510 only).Configure with voice-card x.  Then codec complexity (flex | high | medium). The DSP treats all calls according to its configured complexity, regardless of the actual complexity of the codec of the call. A resource with configured complexity equal or higher than the actual complexity of the incoming call must be available, or the call will fail.

3725 with NM-HDV in slot 0
!
Gateway#conf t
Gateway(config)#voice-card 0
Gateway(config-voicecard)#codec complexity ?
high    Set codec complexity high. High complexity, lower call density.
medium  Set codec complexity medium. Mid range complexity and call  density.
<cr>
Gateway(config-voicecard)#end

2811 with PVDM2-16 installed on main board.
!
GW_2811#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
GW_2811(config)#voice-card 0
GW_2811(config-voicecard)#codec complexity ?
flex    Set codec complexity Flex. Flex complexity, higher call density.
high    Set codec complexity high. High complexity, lower call density.
medium  Set codec complexity medium. Mid range complexity and call density.

GW_2811(config-voicecard)#end
GW_2811#

For example, if a call requires a high-complexity codec but the DSP resource is configured for medium complexity mode, the call will fail. However, if a medium-complexity call is attempted on a DSP configured for high complexity mode, then the call will succeed and Cisco IOS will allocate a high-complexity mode resource.

Voice cards that do not have C5510 DSPs can be configured only for medium or high complexity. Voice cards that are equipped with C5510 DSPs have an additional complexity option called flex complexity. Setting the codec complexity to medium or high sets the number of voice terminations per DSP to a static number. Flex mode has an advantage when calls of multiple codecs must be supported on the same hardware because flex mode can support more calls than when the DSPs are configured as medium or high complexity. However, flex mode does allow oversubscription of the resources, which introduces the risk of call failure if all resources are used. With flex mode it is possible to have fewer DSP resources than with physical TDM interfaces.

DSP Sharing & Farming:

DSP sharing and DSP farming has been used interchangeably. Cisco IOS dspfarm command is used for both DSP sharing and DSP farming. The DSP farming term was originally used to describe using DSPs as media resources for CallManager. DSP sharing allows C5510 DSPs to terminate a voice call from a voice port that is located in another hardware slot. This can reduce the possibility of oversubscription when using flex complexity. It can also make it easier to add DSPs to an existing gateway. It is physically much easier to add PVDM2s to an NM-HDV2 than it is to add them to the main board of an ISR.

  • A local DSP is on the same voice card as the voice port.
  • A remote DSP is on a different voice card than the voice port.
  • The DSPs on the main board of an ISR are local to the High-Performance WAN Interface Card (HWIC) and Extension Voice Module (EVM) slots and are remote to the NM slots.
  • DSP sharing supports only voice termination not transcoding.
  • DSP sharing is supported on T1/E1 interfaces only.
  • DSP sharing is supported on PVDM2s that are installed on the main board of 2800 and 3800 ISRs.
  • DSP sharing is supported on NM-HDV2s that are installed in a 2800, 3700, or 3800 router.
  • All voice cards that share DSPs must have synchronized clocks.

You should configure all voice cards that share DSPs for the same complexity.
GW_2811(config)#voice-card 0
GW_2811(config-voicecard)#dspfarm
GW_2811(config-voicecard)#end

Please refer to configuration for IOS Transcoding and Hardware Conferencing.

Transcoding & MTP Resources:

Transcoding can be configured on following devices:

  • WS-X6608-T1/E1
  • WS-SVC-CMM-ACT
  • PVDM installed in NM-HDV
  • PVDM2s installed in NM-HDV2
  • PVDM2s installed in ISRs
  • NM-HD-1V/2V/2VE (C5510)
  • 1751/1760

Maximum number of transcoding sessions per device:

Device {Max Sessions}

WS-6608-T1/E1 {24 per port, 192 per module}
WS-SVC-CMM-ACT {64}
C549 {4}
C549 in 1751/1760  {2}
C5510 medium complexity {8}
C5510 high complexity {6}
c5510 flex complexity {16*}

* It is only possible to support 16 transcoding sessions when you are transcoding between two low- complexity codecs. Because this situation is rare, the practical maximum number of transcoding sessions per DSP is 8.

Note: Software-based MTPs can support two voice streams with the same packetization rates. If the voice streams use different packetization rates, a DSP is required. The number of software-based MTP sessions is CPU bound and varies per router platform. You can configure only the C5510 DSP to provide hardware-based MTP services. Each DSP can support 16 MTP sessions. If a call requires MTP services and no MTP is configured, a transcoder is used if available.

Conferencing:

You need to consider only one factor when calculating conference bridge DSP requirements: the number of conferences required.For example, the C5510 supports two mixed-mode conferences with up to eight participants each. Therefore, it is technically accurate to say that the C5510 supports 16 conference participants. But this does not mean we can have 4 conferences of 4 participants each. Number of DSPs required depends on number of Conferences. Particpants per conference are irrelevant.

Device {Max Conference – Max participant}

C549                               {1 – 6}
C5510 (G.711 only)           {8 – 8}
C5510 (G.729a/G.729)     {2 – 8}

E1 Card & PVDM:

How many DSPs/PVDM are required as per E1?

As a rule of thumb always consider One PVDM2-64 for 2 E1s. Each E1 takes up 30 channels (2×30 = 60 > 64). If you are using 1 x E1 then you may use one PVDM2-32.

A PVDM-12 or PVDM2 (32 or higher) can provide voice termination, transcoding, and conferencing simultaneously. The restriction on conferencing is per DSP, not per PVDM. The gateway does track the number of voice ports that are allocated to prevent oversubscription of DSPs. Even though the DSPs are not assigned to a specific voice port, the number of DSPs available for other purposes has been reduced.

You can also use Cisco DSP Calculator to find out DSP resources needed as per requirement.

Useful Commands:

sh voice dsp voice

show voice dsp group all

show dspfarm all

Show dspfarm dsp active

Gateway Outputs:

This is from a gateway which is using on-board PVDM-12 chips.

Show diag#

Slot 2:
High Density Voice Port adapter
Port adapter is analyzed
Port adapter insertion time unknown
EEPROM contents at hardware discovery:
Hardware Revision        : 1.1
Top Assy. Part Number    : 800-03567-01
Board Revision           : E0
Deviation Number         : 0-0
Fab Version              : 02
PCB Serial Number        : JAB04390KNG
RMA Test History         : 00
RMA Number               : 0-0-0-0
RMA History              : 00
Product (FRU) Number     : NM-HDV=
EEPROM format version 4
EEPROM contents (hex):
0x00: 04 FF 40 00 CC 41 01 01 C0 46 03 20 00 0D EF 01
0x10: 42 45 30 80 00 00 00 00 02 02 C1 8B 4A 41 42 30
0x20: 34 33 39 30 4B 4E 47 03 00 81 00 00 00 00 04 00
0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

HDV SIMMs: Product (FRU) Number: PVDM-12
SIMM slot 0: Empty.
SIMM slot 1: Empty.
SIMM slot 2: PVDM-12 SIMM present.
SIMM slot 3: PVDM-12 SIMM present.
SIMM slot 4: PVDM-12 SIMM present.
.

GWY01#sh voice dsp

DSP  DSP             DSPWARE CURR  BOOT                         PAK     TX/RX
TYPE NUM CH CODEC    VERSION STATE STATE   RST AI VOICEPORT TS ABORT  PACK COUNT
==== === == ======== ======= ===== ======= === == ========= == ===== ============
C549 007 01 {medium}  4.1.45 IDLE  idle      0  0 2/0:15    01     0 95382631/933
51746
02 {medium}  4.1.45 IDLE  idle         0 2/0:15    02     0 47552148/467
89172
03 {medium}  4.1.45 IDLE  idle         0 2/0:15    03     0 20910677/206
87231
04 {medium}  4.1.45 IDLE  idle         0 2/0:15    04     0 8394645/8321
251
C549 008 01 {medium}  4.1.45 IDLE  idle      0  0 2/0:15    05     0 3004228/3000
106
02 {medium}  4.1.45 IDLE  idle         0 2/0:15    06     0 983950/97893
8
03 {medium}  4.1.45 IDLE  idle         0 2/0:15    07     0 538659/54259
5
04 {medium}  4.1.45 IDLE  idle         0 2/0:15    08     0 2102367/2139
512
C549 009 01 {medium}  4.1.45 IDLE  idle      0  0 2/0:15    09     0 8154416/8309
524
02 {medium}  4.1.45 IDLE  idle         0 2/0:15    10     0 23548128/239
63817
03 {medium}  4.1.45 IDLE  idle         0 2/0:15    11     0 56429286/574
41003
04 {medium}  4.1.45 IDLE  idle         0 2/0:15    12     0 106057197/10
7984725

This is from another gateway using PVDM2-32 & PVDM2-16:

GW_WCH_01#sh voice dsp group all

DSP groups on slot 0:
dsp 1:
State: UP, firmware: 4.4.24
Max signal/voice channel: 16/16
Max credits: 240
Group: FLEX_GROUP_VOICE, complexity: FLEX
Shared credits: 150, reserved credits: 0
Signaling channels allocated: 16
Voice channels allocated: 6
Credits used: 90
Voice channels:
Ch01: voice port: 0/0/0:15.29, codec: g711ulaw, credits allocated: 15
Ch02: voice port: 0/0/0:15.3, codec: g711alaw, credits allocated: 15
Ch03: voice port: 0/0/0:15.1, codec: g711alaw, credits allocated: 15
Ch04: voice port: 0/0/0:15.2, codec: g711alaw, credits allocated: 15
Ch05: voice port: 0/0/0:15.4, codec: g711alaw, credits allocated: 15
Ch06: voice port: 0/0/0:15.31, codec: g711alaw, credits allocated: 15

dsp 2:
State: UP, firmware: 4.4.24
Max signal/voice channel: 16/16
Max credits: 240
Group: FLEX_GROUP_VOICE, complexity: FLEX
Shared credits: 225, reserved credits: 0
Signaling channels allocated: 16
Voice channels allocated: 1
Credits used: 15
Voice channels:
Ch01: voice port: 0/0/0:15.5, codec: g711alaw, credits allocated: 15

dsp 5:
State: UP, firmware: 4.4.24
Max signal/voice channel: 16/16
Max credits: 240
Group: FLEX_GROUP_VOICE, complexity: FLEX
Shared credits: 240, reserved credits: 0
Signaling channels allocated: 2
Voice channels allocated: 0
Credits used: 0

DSP groups on slot 1:
This command is not applicable to slot 1

DSP groups on slot 2:
This command is not applicable to slot 2

0 DSP resource allocation failure

GW_WCH_01#sh voice dsp

DSP  DSP                DSPWARE CURR  BOOT                         PAK     TX/RX
TYPE NUM CH CODEC       VERSION STATE STATE   RST AI VOICEPORT TS ABORT  PACK COUNT
==== === == ======== ========== ===== ======= === == ========= == ===== ============

—————————-FLEX VOICE CARD 0 ——————————
*DSP VOICE CHANNELS*
DSP   DSP                DSPWARE CURR  BOOT                         PAK   TX/RX
TYPE  NUM CH CODEC       VERSION STATE STATE   RST AI VOICEPORT TS ABRT PACK COUNT
===== === == ======== ========== ===== ======= === == ========= == ==== ============
C5510 001 01 g711alaw     4.4.24 busy  idle      0  0 0/0/0:15  01    0    3128/3041
C5510 001 02 g711alaw     4.4.24 busy  idle      0  0 0/0/0:15  02    0  10125/10293
C5510 001 03 g711alaw     4.4.24 busy  idle      0  0 0/0/0:15  03    0    1432/1215
*DSP SIGNALING CHANNELS*
DSP   DSP                DSPWARE CURR  BOOT                         PAK   TX/RX
TYPE  NUM CH CODEC       VERSION STATE STATE   RST AI VOICEPORT TS ABRT PACK COUNT
===== === == ======== ========== ===== ======= === == ========= == ==== ============
C5510 001 01 {flex}       4.4.24 alloc idle      0  0 0/1/1     06    0         18/0
C5510 001 02 {flex}       4.4.24 alloc idle      0  0 0/1/0     06    0        442/0
C5510 001 03 {flex}       4.4.24 alloc idle      0  0 0/1/3     02    0         18/0
C5510 001 04 {flex}       4.4.24 alloc idle      0  0 0/1/2     02    0        110/0
————————END OF FLEX VOICE CARD 0 —————————-

GW_WCH_01#sh voice dsp active

DSP  DSP                DSPWARE CURR  BOOT                         PAK     TX/RX
TYPE NUM CH CODEC       VERSION STATE STATE   RST AI VOICEPORT TS ABORT  PACK COUNT
==== === == ======== ========== ===== ======= === == ========= == ===== ============

—————————-FLEX VOICE CARD 0 ——————————
*DSP ACTIVE VOICE CHANNELS*
DSP      DSPWARE           VOX DSP               SIG DSP            PAK   TX/RX
TYPE     VERSION CODEC    NUM CH TS VOICEPORT SLT NUM CH TS RST AI ABRT PACK COUNT
===== ========== ======== === == == ========= === === == == === == ==== ============
C5510 4.4.24 g711alaw 001 01 01 0/0/0:15  000 001 05 01   0  0    0  15825/15801
C5510 4.4.24 g711alaw 001 02 02 0/0/0:15  000 001 06 02   0  0    0  22822/23053
C5510 4.4.24 g711alaw 001 03 03 0/0/0:15  000 001 07 03   0  0    0  14129/14030
C5510 4.4.24 g711alaw 001 04 04 0/0/0:15  000 001 08 04   0  0    0    6865/5661
C5510 4.4.24 g711alaw 001 05 05 0/0/0:15  000 001 09 05   0  0    0    4636/4588
C5510 4.4.24 g711alaw 002 01 06 0/0/0:15  000 001 10 06   0  0    0    3141/3180
————————END OF FLEX VOICE CARD 0 —————————-

Transcoding SessionsWS-6608-T1/E1 {24 per port, 192 per module}

WS-SVC-CMM-ACT {64}

C549 {4}

C549 in 1751/1760  {2}

C5510 medium complexity {8}

C5510 high complexity {6}

c5510 flex complexity {16*}

* It is only possible to support 16 transcoding sessions when you are transcoding between two low- complexity codecs. Because this situation is rare, the practical maximum number of transcoding sessions per DSP is 8.

Advertisements

Customer reported a fault that several fax machines which were working fine last week have suddenly stopped working. All they were getting for incoming faxes was just the header. No content of the actual fax.

Rule of thumb – anything which was working before and not working now means something must have changed. I jumped on the main Voice gateway which was connected to the switch and the Fax machines were connected to the VG224. A typical depiction could be as follows:

PSTN >> VGW >> SW >> VG224 >> FAX

There were 3x E1 cards on the Voice gateway. One of them was connected to PSTN which was used for incoming/outgoing calls, the other one was connected to Meridian PBX system and the third one to Investec DealerBoard.

E1 0/0/0 – PBX
E1 0/1/0 – ISDN30
E1 0/2/0 – Dealer Board

I first checked the network-clock-participate and network-clock-select as they are very important for Fax issues. I found  this:
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-participate wic 2
network-clock-select 1 E1 0/0/0

So the Primary clock source was Meridian PBX side. I then checked the controllers and found as follows:

E1 0/1/0  – Connected to ISDN PSTN  – faxes are coming on this line

Total Data (last 24 hours)
0 Line Code Violations, 0 Path Code Violations,
18475 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
18475 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

LON-VG1-3825#

E1 0/2/0 – Connected to ITS Dealerboard

195 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Total Data (last 24 hours)
0 Line Code Violations, 0 Path Code Violations,
18701 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
18701 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

!

I found the issue. The E1 had so many Slip seconds and that was the main reason for fax issues. I later found out that there was some planned work carried out by third party which changed some configuration at the Meridian PBX side. This obviously created some clocking issues. I re-configured the clock-select as follows:

no network-clock-select 1 E1 0/0/0
network-clock-select 1 E1 0/1/0
network-clock-select 2 E1 0/0/0

This way I made the PSTN as main clocking source which eliminated the slip seconds issue and the fax started working.

Problem description:

One of my customer reported an issue with their VG224. All Polycom conference phones connected to the Vg224 were facing an strange issue of DTMF tones not recognized by PSTN. Users trying to get into a MeetMe conference were having  tough time as their pin was not getting recognised.

Analysis & Observations:

This issue was passed onto me after some of my colleagues already spent few days trying all sort of things for resolution. I found out from the customer that the phones never worked properly ever since they hooked them in VG224. One thing was clear from this statement that nothing changed on Vg224 or on their network as this has been a known issue since they started using VG224.

I checked the gateway which was a SCCP configured VG224. For your information let me share how a SCCP VG224 is configured:

Configuration:

service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!

!
no aaa new-model
clock timezone GMT 0
clock summer-time BST recurring
!
!
!
stcapp ccm-group 10
stcapp
!
voice-card 0
!
!
!
voice service voip
fax protocol none
modem passthrough nse codec g711ulaw
!
!
!
!
!
!
!
!
!
!

archive
log config
hidekeys
!
!
!
class-map match-any Voice-RTP
match ip dscp ef
match ip rtp 16384 16383
class-map match-any Voice-Cntl
match ip dscp af31
!
!
policy-map QoS-LAN-Policy
class Voice-RTP
set cos 5
class Voice-Cntl
set cos 3
!
!
!
interface FastEthernet0/0
description ### Trunk to EIG LAN ###
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description ### Management VLAN ###
encapsulation dot1Q 1 native
ip address 10.1.2.175 255.255.0.0
!
interface FastEthernet0/0.205
description ### Voice Server VLAN ###
encapsulation dot1Q 205
ip address 10.205.2.175 255.255.0.0
service-policy output QoS-LAN-Policy
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.205.1.1
!
no ip http server
!
access-list 30 permit 10.1.5.1
access-list 30 permit 10.200.4.216
snmp-server community E1GpUb73 RO 30
snmp-server community 3I6pR186e RW 30
snmp-server trap-source FastEthernet0/0.1
!
!
control-plane
!
!
!
voice-port 2/0
input gain 14
cptone GB
timeouts ringing infinity
impedance 900r
!
voice-port 2/1
cptone GB
timeouts ringing infinity
!
voice-port 2/2
cptone GB
timeouts ringing infinity
!
voice-port 2/3
cptone GB
timeouts ringing infinity
!
voice-port 2/4
cptone GB
timeouts ringing infinity
!
voice-port 2/5
cptone GB
timeouts ringing infinity
!
voice-port 2/6
cptone GB
timeouts ringing infinity
!
voice-port 2/7
cptone GB
timeouts ringing infinity
!
voice-port 2/8
cptone GB
timeouts ringing infinity
!
voice-port 2/9
cptone GB
timeouts ringing infinity
!
voice-port 2/10
cptone GB
timeouts ringing infinity
!
voice-port 2/11
cptone GB
timeouts ringing infinity
!
voice-port 2/12
cptone GB
timeouts ringing infinity
!
voice-port 2/13
cptone GB
timeouts ringing infinity
!
voice-port 2/14
cptone GB
timeouts ringing infinity
!
voice-port 2/15
cptone GB
timeouts ringing infinity
!
voice-port 2/16
cptone GB
timeouts ringing infinity
!
voice-port 2/17
cptone GB
timeouts ringing infinity
!
voice-port 2/18
cptone GB
timeouts ringing infinity
!
voice-port 2/19
cptone GB
timeouts ringing infinity
!
voice-port 2/20
cptone GB
timeouts ringing infinity
!
voice-port 2/21
cptone GB
timeouts ringing infinity
!
voice-port 2/22
cptone GB
timeouts ringing infinity
!
voice-port 2/23
cptone GB
timeouts ringing infinity
!
!
!
sccp local FastEthernet0/0.205
sccp ccm 10.210.2.1 identifier 1 version 4.1
sccp ccm 10.210.4.1 identifier 2 version 4.1
sccp ccm 10.205.250.1 identifier 3 version 4.1
sccp
!
sccp ccm group 10
associate ccm 2 priority 1
associate ccm 3 priority 2
associate ccm 1 priority 3
!
!
dial-peer voice 200 pots
description ### Dial Peer for Port 2/0 ##
service stcapp
port 2/0
!
dial-peer voice 201 pots
description ### Dial Peer for Port 2/1 ##
service stcapp
port 2/1
!
dial-peer voice 202 pots
description ### Dial Peer for Port 2/2 ##
service stcapp
port 2/2
!
dial-peer voice 203 pots
description ### Dial Peer for Port 2/3 ##
service stcapp
port 2/3
!
dial-peer voice 204 pots
description ### Dial Peer for Port 2/4 ##
service stcapp
port 2/4
!
dial-peer voice 205 pots
description ### Dial Peer for Port 2/5 ##
service stcapp
port 2/5
!
dial-peer voice 206 pots
description ### Dial Peer for Port 2/6 ##
service stcapp
port 2/6
!
dial-peer voice 207 pots
description ### Dial Peer for Port 2/7 ##
service stcapp
port 2/7
!
dial-peer voice 208 pots
description ### Dial Peer for Port 2/8 ##
service stcapp
port 2/8
!
dial-peer voice 209 pots
description ### Dial Peer for Port 2/9 ##
service stcapp
port 2/9
!
dial-peer voice 210 pots
description ### Dial Peer for Port 2/10 ##
service stcapp
port 2/10
!
dial-peer voice 211 pots
description ### Dial Peer for Port 2/11 ##
service stcapp
port 2/11
!
dial-peer voice 212 pots
description ### Dial Peer for Port 2/12 ##
service stcapp
port 2/12
!
dial-peer voice 213 pots
description ### Dial Peer for Port 2/13 ##
service stcapp
port 2/13
!
dial-peer voice 214 pots
description ### Dial Peer for Port 2/14 ##
service stcapp
port 2/14
!
dial-peer voice 215 pots
description ### Dial Peer for Port 2/15 ##
service stcapp
port 2/15
!
dial-peer voice 216 pots
description ### Dial Peer for Port 2/16 ##
service stcapp
port 2/16
!
dial-peer voice 217 pots
description ### Dial Peer for Port 2/17 ##
service stcapp
port 2/17
!
dial-peer voice 218 pots
description ### Dial Peer for Port 2/18 ##
service stcapp
port 2/18
!
dial-peer voice 219 pots
description ### Dial Peer for Port 2/19 ##
service stcapp
port 2/19
!
dial-peer voice 220 pots
description ### Dial Peer for Port 2/20 ##
service stcapp
port 2/20
!
dial-peer voice 221 pots
description ### Dial Peer for Port 2/21 ##
service stcapp
port 2/21
!
dial-peer voice 222 pots
description ### Dial Peer for Port 2/22 ##
service stcapp
port 2/22
!
dial-peer voice 223 pots
description ### Dial Peer for Port 2/23 ##
service stcapp
port 2/23
!
!
!
line con 0
login local
line aux 0
line vty 0 4
login local
!
ntp clock-period 17179905
ntp server 10.1.1.2
end

I found nothing wrong in the config. I checked the IOS which was running on the gateway since they started using it. The IOS was 12.4(15)T5. I decided to do a bug scrub before I further dive into it. A little use of my  googling skills and I found the issue. This particular IOS for VG224 has a well known bug CSCsg85602. The bug description is “DTMF tones not recognised on calls to PSTN from VG224 due to tone leakage”.

This bug was introduced in DSPware 9.4.5 and seems to be causing the problem. I found out that One possible solution was by downgrading the DSPware on the VG224 (while leaving the IOS at 12.4(15)T5 from 9.4.5 to 9.4.4. Then I read about it and realized this has not always resolved the issue.

After going through several release notes I decided to upgrade the IOS to 12.4(15)T13 which was a stable MD release.

Upgarded the IOS and the issue was gone!